MySql Backup

Welcome Guest Search | Active Topics | Log In | Register
Encoding problem with Portuguese characters Options · View
MB
#1 Posted : Friday, August 17, 2012 4:35:51 AM
Rank: Guest

Groups: Registered

Joined: 8/10/2009
Posts: 1,024
Hello.

The backup is working ok in schedule and sending emails and all, but the Portuguese special characters are being replaced by weird stuff.

I have a database with the following setup:
- Character set: latin1
- Collation: latin1_swedish_ci

To restore I uncompressed the zip file and run the file in HeidiSQL 7.0. Everything works fine except for the Portuguese characters.

I opened the SQL file in Notepad++ and the encoding of the file in in ANSI and the characters are bad... I changed it to UTF-8 and the characters became right. But when I try to load this sql file to run in HeidiSQL I get an error:

Code:

-- MySQL dump 10.13  Distrib 5.5.21, for Win32 (x86)
--
-- Host: 127.0.0.1    Database: guias
-- ------------------------------------------------------
-- Server version    5.0.88-community-nt

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/* SQL Error (1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-- MySQL dump 10.13  Distrib 5.5.21, for Win32 (x86)
--
-- Host: 127.0.0.1 ' at line 1 */


Am I doing something wrong?
Could this be a problem still not found by anyone?

Thanks in advanced,
MB
alexs
#2 Posted : Monday, August 20, 2012 4:30:09 AM
Rank: Administration

Groups: Administrators, Registered

Joined: 7/12/2012
Posts: 194
Hello,

Looks like you doing correct and issue can be fixed by way http://nathan.rambeck.or...coding-issues-mysqldump

We'll add support of option "--default-character-set=utf8" in the nearest release.

Thank you for the bug report.
MB
#3 Posted : Monday, August 20, 2012 6:47:28 AM
Rank: Guest

Groups: Registered

Joined: 8/10/2009
Posts: 1,024
Thank you. :-)
I have better suport here than with some big name companies. :-)
AlexP
#4 Posted : Thursday, August 23, 2012 4:29:12 AM
Rank: Administration

Groups: Administrators, Registered

Joined: 12/1/2011
Posts: 822
Hi,

The option is added into the latest release 1.4.9. So, you should get script files in utf-8 character set by default... but I'm not sure if it helps you to resolve this issue.
Please try to use mysqldump file of your version MySQL. You can copy an original mysqldump.exe file into the application's folder with "mysqldump-<major>_<minor>.exe" name. Where <major> and <minor> are major and minor version number of MySQL server.
MBorges
#5 Posted : Friday, August 24, 2012 5:14:52 AM
Rank: Newbie

Groups: Registered

Joined: 8/21/2012
Posts: 2
Location: Lisbon
I tested and now it is working great. All I have to do is say the encoding is utf-8 instead of auto-detect.

Thanks a lot my friend once again. :-)
Alexander Omelchenko
#6 Posted : Thursday, August 18, 2016 5:58:48 AM
Rank: Advanced Member

Groups: Administrators, Registered

Joined: 12/23/2015
Posts: 457
Great! Please feel free to contact us on any issues or concerns.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You can create polls in this forum.
You can vote in polls in this forum.

©Pranas.NET Sql Server Backup MySql Backup Free SQl Backup SQL Backup Master Employee monitoring software Web Scraping Azure SQL Database Backups ergonotes.com